Nothing has changed, new application same error!

Totally NEW project
Build failed :expressionless:
Step 6 script Flutter build aab and automatic versioning exited with status code 1
and here is the project number : 659ab7d5441633338c126b87


Hi @mohd, I encountered the same issue when I rebuilt my apps for the second time. It worked fine during the initial build, but the error recurred when I tested it again.

1 Like

Well i don’t wonna sound horrible, but this screen shot came after the 2nd try.
I will try a third time when i go home againp

Hey @mohd, thanks for reporting it, and I am sorry for you facing a bug while building. Actually, this is not the same problem as before, this is a problem related to your project specifically (if you click on the red message you can see the details of it).

So the problem with your project was with the TabView in pageseven screen specifically, I am not sure exactly what you did, but one of the tabs has two texts at the same time, which causing the error.

We will invistage more to see the reason and prevent it to happen again, but for now if you want to build you can fix it yourself by editing the code by doing the following:

  1. in your project files (bottom left of Nowa), open pageseven.dart
  2. Remove the line 79 and 80, and click save
  3. Check back to the Tabview to see if the text visible is what you wanted, otherwise just edit it from there

As another solution, you can simply remove the TabView from that screen and add it again.

I have checked the project, and if you do one of those two your build will work fine :slight_smile:

Let me know if you have any futher question, I am here always to help.

i will gladly remove it or change it if this is the issue.
let me check it out and hope no error comes up

Hi anas
I have deleted the view tab which was causing the error on page 7, build the app and it worked on both mobiles (android)
now i have created new tabview and did insert the new tabview in the same location.
and made a new button in the main page (i add interstitial ad) and yes i used the correct ADunit.
in the build it showed me a new error inside

Running Gradle task 'bundleRelease'...                          
One or more plugins require a higher Android NDK version.
Fix this issue by adding the following to /Users/builder/clone/android/app/build.gradle:
android {
  ndkVersion "25.1.8937393"

Error: Invalid package URI 'package:import%20':
  Invalid argument (packageUri): Package URIs must start with the package name followed by a '/': Instance of '_Uri'.
lib/main.dart:3:8: Error: Expected ';' after this.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:25: Error: Variables must be declared using the keywords 'const', 'final', 'var' or a type name.
Try adding the name of the type of the variable or the keyword 'var'.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:25: Error: Expected ';' after this.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:32: Error: Expected a declaration, but got ':'.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:33: Error: Variables must be declared using the keywords 'const', 'final', 'var' or a type name.
Try adding the name of the type of the variable or the keyword 'var'.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:33: Error: Expected ';' after this.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:48: Error: Expected a declaration, but got '/'.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:49: Error: A function declaration needs an explicit list of parameters.
Try adding a parameter list to the function declaration.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:64: Error: Expected '{' before this.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:49: Error: 'nowa_mobile_ads' is already declared in this scope.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:33: Context: Previous declaration of 'nowa_mobile_ads'.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:64: Error: Expected a declaration, but got '.'.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:65: Error: Variables must be declared using the keywords 'const', 'final', 'var' or a type name.
Try adding the name of the type of the variable or the keyword 'var'.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:65: Error: Expected ';' after this.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:69: Error: Expected a declaration, but got '';''.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:72: Error: Unexpected token ';'.
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:3:8: Error: Not found: 'package:import%20'
import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';
lib/main.dart:25:3: Error: Undefined name 'MobileAds'.
Unhandled exception:
FileSystemException(uri=org-dartlang-untranslatable-uri:package%3Aimport%2520; message=StandardFileSystem only supports file:* and data:* URIs)
#0      StandardFileSystem.entityForUri (package:front_end/src/api_prototype/standard_file_system.dart:34:7)
#1      asFileUri (package:vm/kernel_front_end.dart:732:37)
#2      writeDepfile (package:vm/kernel_front_end.dart:870:21)
<asynchronous suspension>
#3      FrontendCompiler.compile (package:frontend_server/frontend_server.dart:676:9)
<asynchronous suspension>
#4      starter (package:frontend_server/starter.dart:102:12)
<asynchronous suspension>
#5      main (file:///Volumes/Work/s/w/ir/x/w/sdk/pkg/frontend_server/bin/frontend_server_starter.dart:13:14)
<asynchronous suspension>

Target kernel_snapshot failed: Exception

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:compileFlutterBuildRelease'.
> Process 'command '/Users/builder/programs/flutter/bin/flutter'' finished with non-zero exit value 1

* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.

* Get more help at

BUILD FAILED in 1m 32s
Running Gradle task 'bundleRelease'...                             93.0s
Gradle task bundleRelease failed with exit code 1

Build failed :|
Step 6 script `Flutter build aab and automatic versioning` exited with status code 1```

could this be because i have Admob banner in the 1st page and interstitial ad in the button located in the 1st page too ?

Hey @mohd, no you should be fine with adding admob and interstitial ad, but it seems the problem is related to Admob. Did you uncheck the test box for the admob banner and interstitial ads?

because if any of them are in the the testing mode, you won’t be able to deploy as a release app

all of them are “not” show test ads
i tried codemagic and showing me the same error

i downloaded the code, the only error is showing redline on this line at android studio

import 'package:import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';';

by the way, i have removed the interstitial ad from the button and kept only the banner ad

could this be the error ?
the 3rd line.
am no expert but the construction of the import is little off and it is not green like others

on pageone.dart it is like this

import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';

if you can confirm it, i can remove and change it to the correct line

Hey @mohd, thanks for reporting that! yes that is defeintly causing the problem since the build didn’t recgonize Admob cause of the error in importing it.

We will fix the code generation error, but for now you can simply just fix it as you did already by replacing that import with

import 'package:nowa_mobile_ads/nowa_mobile_ads.dart';

Let me know if the problem is solved afterwards.

Inside nowa, it refuses to any modification on the code, when i change the code and press save (inside the editor) it is automatically change it back to the wrong code.

Good morning
Just to give an update, on Nowa it refuses to manually change the line of code (i can add but if it now allowing me on that special line and i dont know why)

For testing, i download the code, lunched the android studio, made my edits and used codemagic for test building.

  1. Codemagic APK code came 225 MB which is huge and of course am not using that built.
  2. Android studio kept hitting me with errors about SDK numbers and other errors.

So if you can make this udjustment to my main.dart manually so i can built it on Nowa directly.


This is the error in the coding inside nowa itself

if you can manually adjust it or fix the issue, that would be great.
My app is ready to be built

Thanks @mohd for reporting it! we will release a new version today as a hot fix for many problems, and this will be one of them.

We will annouce it as soon as we release it :slight_smile:

1 Like

Thank you.
I will be waiting

A walkthough this error (not a permanent solution)
But few bugs appeared as well since 3 days.

Every time i try to edit the code manually, and press save (editor’s button) the code automatically change back to the original wrong code.
So what i did is i kept the code page open and pressed on the main top save button and went to build the application, and it worked :blush:

Also the bug that appeared days ago, i keep loosing main page, every time i go inside my app i have to go to page 1 and click to make it home page.

Another issue that the icon image still has issue, i changed it from 1200x1200 to 590x590, size from 900kb to 530 kb i think, and flutter base icon just appears
Screenshot_20240123_123012_One UI Home

This is just now, built minuets ago

Another update
although i used the generate the key from NOWA, when i uploaded the file in google console, it didnt recognized my keys and i made google to generate it’s own key instead

this also might needs a check up

Hey @mohd, thanks for sharing all of that! today we will take a look on everything you reported and get back to you as soon as possible! but are those problems are also in the same project that you shared it’s ID with us earlier?