Close work cycle with NOWA

Hello. I must close my work cycle before adopting NOWA. What I’m looking for is: 1 generate a project with Nowa, 2 Download the project, 3 be able to run it on my PC with vscode+flutter. I fulfilled 1 and 2 but not 3. I have no errors but it doesn’t work. Any key? Thank you so much

Hey @claudioc, welcome to the community! can you please share more of how it doesn’t work by runing it on your PC with vscode and flutter? when you download the project, it should be a normal flutter app that you can simply open in VS code and start editing.

Or do you mean a problem when you run the app on the emulator?

First thanks for your response. Download, unzip and update the version of dart. F5 and there are no errors or messages but it is as you say, I ran the app in the emulator. Could the problem be there?

If it’s Android Emulator then yes it won’t work for now because we had a bug, but it’s fix should be released today (hopefully).

You can try with iOS emulator if you have a MacOS, then it should work with no problem :slight_smile:

1 Like

Hello again. Connect a ‘physical’ Android device. I ran other examples and they worked fine. When running what was downloaded from NOWA, under the same conditions, the same problem occurs. (it would not be the emulator that caused it) I copy the screen with the console message. I hope to be helpful.

Hey @claudioc, Yes we had this problem as I mentioned above with building for Android, but now we released a version (1.4) that fixed it.

Be sure you have 1.4 and try again, it should work :slight_smile:

Check out the release notes

1 Like

Great, what a resolution speed. Very good support. Greetings from Buenos Aires. :clap: :clap:

1 Like

Hello again. I still have the same problem. I did the following:

  1. Delete all projects in NOWA

  2. Create a simple project in NOWA, save and download

  3. I copied folders from the zip and opened with VSC, ran it on a physical device and got the same error in the build.

  4. Run “dart fix --apply” and it gave the same error

  5. Created a simple project in VSC and ran it successfully on mobile

I hope to overcome this step to be able to adopt NOWA asap

Hello again. Everything solved, everything works fine. Download a simple example with version 1.4.2 and it works perfectly. I close this thread with a hit from Nowa. Now we will start producing. Thank you

1 Like

Thanks @claudioc, I am happy it all works now :slight_smile: let me know if you faced any other problem, we are here for you!